Saving on Credit Card Transactions: An Update

Are you saving on credit card transactions? If you are, great! Read on, because PayPal has upgraded the protocols used to secure all external connections made to their systems, and you may need to update your system as well.

And if you’re not saving on credit card transactions, why not? First, read our blog post on how we are able to help you do this. Second, come on back here and learn about this important update.

As we said before: as of June 30, 2017, PayPal is upgrading the protocols used to secure all external connections made to their systems. Transport Layer Security version 1.2 (TLS 1.2) and Hypertext Transfer Protocol version 1.1 (HTTP/1.1) will become mandatory for communication with PayPal. Given these changes, it is necessary to apply a patch to the Authorization Service Lite (ASL) component used by the PayPal integration with Vantage/Epicor ERP.

More information about the reason for the upgrade can be found on the PayPal site.

How do I know if I have the problem?

All companies using Credit Card Processing in Vantage, Vista, Epicor ERP v9, or Epicor ERP v10 will be affected by these changes and need to install the update.

Customers using Epicor ERP version 10.1.600 will not be required to make these changes as they are already supported.

How do I obtain the updates? 

There are two elements that need to be updated and are detailed in these instructions. Both the update to the operating system environment (1) and the Epicor program .dll file (2) need to be made to ensure compliance with the changes.

(1) The operating system patch is available for download from Microsoft support:

Windows 7 & Windows Server 2008 R2

Windows 8 & Windows Server 2012

Windows 8.1 & Windows Server 2012 R2

Windows 10 & Windows Server 2016

(2) The Epicor program “.dll” files are located on EPICweb under product downloads:

Vantage 8.03.400

Vista 8.03.400

EPR 9.05.700

EPR 9.05.600

EPR 9.04.500

EPR 10.0

EPR 10.1

ERP 10.1.500

Important Note: There is no Hot Fix for Windows XP, Windows Server 2003, Windows Vista and Windows Server 2008 (not R2) since Microsoft doesn’t provide support for TLS 1.2 on these Operating Systems. This means ASL will no longer work on those versions of Windows and the installation needs to be moved to a different machine with a compatible Operating System.

Of course, if you have any questions about making the change, you can contact us and we’ll be glad to help. Saving the day, saving you money: That’s the Encompass way.